Configuration Example of OSPF-HUAWEI

*******OSPF Configuration – GPON*******

  1. Configure OLT-1.
    1. Configure the IP address of the L3 interface.
      OLT-1(config)#vlan 2 smart
      OLT-1(config)#port vlan 2 0/19 0
      OLT-1(config)#interface vlanif 2
      OLT-1(config-if-vlanif2)#ip address 192.1.1.1 24
      OLT-1(config-if-vlanif2)#quit
    2. Configure the OSPF Router ID.
      OLT-1(config)#router id 1.1.1.1
    3. Enable OSPF.
      OLT-1(config)#ospf
      OLT-1(config-ospf-1)#area 0
      OLT-1(config-ospf-1-area-0.0.0.0)#network 192.1.1.0 0.0.0.255
      OLT-1(config-ospf-1-area-0.0.0.0)#network 1.1.1.1 0.0.0.0
      OLT-1(config-ospf-1-area-0.0.0.0)#quit
      OLT-1(config-ospf-1)#quit
    4. Configure the OSPF priority.
      OLT-1(config)#interface vlanif 2
      OLT-1(config-if-vlanif2)#ospf dr-priority 100
      OLT-1(config-if-vlanif2)#quit
    5. Save the data.
      OLT-1(config)#save
  2. Configure OLT-2.
    1. Configure the IP address of the L3 interface.
      OLT-2(config)#vlan 2 mux
      OLT-2(config)#port vlan 2 0/19 0
      OLT-2(config)#interface vlanif 2
      OLT-2(config-if-vlanif2)#ip address 192.1.1.2 24
      OLT-2(config-if-vlanif2)#quit
    2. Configure the OSPF Router ID.
      OLT-2(config)#router id 2.2.2.2
    3. Enable OSPF.
      OLT-2(config)#ospf
      OLT-2(config-ospf-1)#area 0
      OLT-2(config-ospf-1-area-0.0.0.0)#network 192.1.1.0 0.0.0.255
      OLT-2(config-ospf-1-area-0.0.0.0)#network 2.2.2.2 0.0.0.0
      OLT-2(config-ospf-1-area-0.0.0.0)#quit
      OLT-2(config-ospf-1)#quit
    4. Configure the OSPF priority.
      OLT-2(config)#interface vlanif 2
      OLT-2(config-if-vlanif2)#ospf dr-priority 80
      OLT-2(config-if-vlanif2)#quit
    5. Save the data.
      OLT-2(config)#save
  3. Configure OLT-3.
    1. Configure the IP address of the L3 interface.
      OLT-3(config)#vlan 2 mux
      OLT-3(config)#port vlan 2 0/19 0
      OLT-3(config)#interface vlanif 2
      OLT-3(config-if-vlanif2)#ip address 192.1.1.3 24
      OLT-3(config-if-vlanif2)#quit
    2. Configure the OSPF Router ID.
      OLT-3(config)#router id 3.3.3.3
    3. Enable OSPF.
      OLT-3(config)#ospf
      OLT-3(config-ospf-1)#area 0
      OLT-3(config-ospf-1-area-0.0.0.0)#network 192.1.1.0 0.0.0.255
      OLT-3(config-ospf-1-area-0.0.0.0)#network 3.3.3.3 0.0.0.0
      OLT-3(config-ospf-1-area-0.0.0.0)#quit
      OLT-3(config-ospf-1)#quit
    4. Configure the OSPF priority.
      OLT-3(config)#interface vlanif 2
      OLT-3(config-if-vlanif2)#ospf dr-priority 90
      OLT-3(config-if-vlanif2)#quit
    5. Save the data.
      OLT-3(config)#save
  4. Configure OLT-4.
    1. Configure the IP address of the L3 interface.
      OLT-4(config)#vlan 2 mux
      OLT-4(config)#port vlan 2 0/19 0
      OLT-4(config)#interface vlanif 2
      OLT-4(config-if-vlanif2)#ip address 192.1.1.4 24
      OLT-4(config-if-vlanif2)#quit
    2. Configure the OSPF Router ID.
      OLT-4(config)#router id 4.4.4.4
    3. Enable OSPF.
      OLT-4(config)#ospf
      OLT-4(config-ospf-1)#area 0
      OLT-4(config-ospf-1-area-0.0.0.0)#network 192.1.1.0 0.0.0.255
      OLT-4(config-ospf-1-area-0.0.0.0)#network 4.4.4.4 0.0.0.0
      OLT-4(config-ospf-1-area-0.0.0.0)#quit
      OLT-4(config-ospf-1)#quit
    4. Save the data.
      OLT-4(config)#save

                                                               ********END********

Be the first to comment

Leave a Reply

Your email address will not be published.


*


For security, use of Google's reCAPTCHA service is required which is subject to the Google Privacy Policy and Terms of Use.

I agree to these terms.