MPLS Configuration in Huawei OLT-HUAWEI

gpontutorials.com-MPLS in Huawei OLT
gpontutorials.com-MPLS in Huawei OLT

***MPLS Configuration in Huawei OLT***

Step 1: Configure the basic MPLS.

  1. Configure a loopback interface.

Set the ID of the loopback interface to 0 and its IP address to 10.10.10.10/32.

OLT-1(config)#interface loopback 0

OLT-1(config-if-loopback0)#ip address 10.10.10.10 32

OLT-1(config-if-loopback0)#quit

  1. Configure the MPLS LSR-ID. Use the IP address of loopback interface 0 as the LSR ID.

OLT-1(config)#mpls lsr-id 10.10.10.10

  1. Enable MPLS globally.

Trigger LDP by the IP address of the host to set up an LSP.

OLT-1(config)#mpls

OLT-1(config-mpls)#lsp-trigger host

OLT-1(config-mpls)#quit

  1. Enable the L2VPN function.

OLT-1(config)#mpls l2vpn

  1. Enable the LDP function globally and enable the split horizon policy.

OLT-1(config)#mpls ldp

OLT-1(config-mpls-ldp)#outbound peer all split-horizon

OLT-1(config-mpls-ldp)#quit

Step 2: Configure VLAN and enable MPLS for VLAN and VLAN interfaces.

  1. Add VLAN 4001 for forwarding MPLS packets and add upstream port 0/19/0 and 0/19/1 to it.

OLT-1(config)#vlan 4001 smart

OLT-1(config)#port vlan 4001 0/19/0

OLT-1(config)#port vlan 4001 0/19/1

  1. Enable MPLS for VLAN 4001.

OLT-1(config)#mpls vlan 4001

  1. Set the IP address of VLAN interface 4001 to 10.50.50.50/24 and enable MPLS LDP for the VLAN interface.

OLT-1(config)#interface vlanif 4001

OLT-1(config-if-vlanif4001)#ip address 10.50.50.50 24

OLT-1(config-if-vlanif4001)#mpls

OLT-1(config-if-vlanif4001)#mpls ldp

OLT-1(config-if-vlanif4001)#quit

Step 3: Configure routes.

VPLS has no special requirements on routing policy. You can use static route, RIP, or OSPF policy. In the following example, OSPF is used.

Set the OSPF process ID to 100 and OSPF area ID to 1. In addition, configure the interfaces (VLAN interface and loopback interface) that run OSPF and configure the areas of the interfaces.

OLT-1(config)#ospf 1

OLT-1(config-ospf-1)#area 100

OLT-1(config-ospf-1-area-0.0.0.100)#network 10.50.50.0 0.0.0.255

OLT-1(config-ospf-1-area-0.0.0.100)#network 10.10.10.10 0.0.0.0

OLT-1(config-ospf-1-area-0.0.0.100)#return

Step 4:  Configure the remote LDP session.

Configure the remote LDP session from the MA5600T/MA5603T/MA5608T to PE3 (LSR ID: 3.3.3.3) and PE4 (LSR ID: 4.4.4.4) respectively. Name the sessions to_pe3 and to_pe4 respectively.

OLT-1(config)#mpls ldp remote-peer to_pe3

OLT-1(config-mpls-ldp-remote-to_pe3)#remote-ip 3.3.3.3

OLT-1(config-mpls-ldp-remote-to_pe3)#remote-ip auto-dod-request

OLT-1(config-mpls-ldp-remote-to_pe3)#quit

OLT-1(config)#mpls ldp remote-peer to_pe4

OLT-1(config-mpls-ldp-remote-to_pe4)#remote-ip 4.4.4.4

OLT-1(config-mpls-ldp-remote-to_pe4)#remote-ip auto-dod-request

OLT-1(config-mpls-ldp-remote-to_pe4)#quit

Step 5: Configure a VSI.

  1. Add a VSI.

Create a VSI named hsi. Set the signaling protocol to LDP. and VSI ID to 1.

OLT-1(config)#vsi hsi

OLT-1(config-vsi-hsi)#pwsignal ldp

OLT-1(config-vsi-hsi)#vsi-id 1

  1. (Optional) Configure the attributes of VSI.

Configure basic attributes of VSI as required, including the encapsulation type, control word, MTU value, and traffic suppression policy. In the following example, the control word is enabled and default values are used for other parameters.

OLT-1(config-vsi-hsi)#control-word

Step 6: Configure PWs.

Create two PWs with IDs 1 and 2. Set the service type to vpls, remote IP addresses to 3.3.3.3 and 4.4.4.4 respectively, and encapsulation type to ethernet tagged. Enable the control word, and set the receive labels of dynamic PW to 10240 and 10250 respectively.

OLT-1(config)#pw-para pwindex 1

OLT-1(config-pw-para-index-1)#service-type vpls

OLT-1(config-pw-para-index-1)#pwid 1

OLT-1(config-pw-para-index-1)#peer-address 3.3.3.3

OLT-1(config-pw-para-index-1)#pw-type ethernet tagged

OLT-1(config-pw-para-index-1)#control-word enable

OLT-1(config-pw-para-index-1)#dyn-receive-label 10240

OLT-1(config-pw-para-index-1)#quit

OLT-1(config)#pw-para pwindex 2

OLT-1(config-pw-para-index-2)#service-type vpls

OLT-1(config-pw-para-index-2)#pwid 2

OLT-1(config-pw-para-index-2)#peer-address 4.4.4.4

OLT-1(config-pw-para-index-2)#pw-type ethernet tagged

OLT-1(config-pw-para-index-2)#control-word enable

OLT-1(config-pw-para-index-2)#dyn-receive-label 10250

OLT-1(config-pw-para-index-2)#quit

Step 7:  Bind PW and VSI.

Dynamically bind PW1 and PW2 to the VSI named hsi to establish the VPLS PW service.

OLT-1(config)#vsi hsi

OLT-1(config-vsi-hsi)#vsi-pw-binding pwindex 1

OLT-1(config-vsi-hsi)#vsi-pw-binding pwindex 2

Step 8: Bind AC and VSI.

Bind VLAN 100 to the VSI named hsi, so that the Internet access service packets of VLAN 100

can be forwarded in the VSI.

OLT-1(config-vsi-hsi)#vsi-ac-binding vlan 100

 

***END***

Be the first to comment

Leave a Reply

Your email address will not be published.


*


For security, use of Google's reCAPTCHA service is required which is subject to the Google Privacy Policy and Terms of Use.

I agree to these terms.